UWATEC IrDA

Discussion of the macOS applications DiveLogDT and Dive Log Manager
support
Posts: 716
Joined: Wed Mar 31, 2010 4:35 pm

Re: UWATEC IrDA

Post by support » Sun Mar 24, 2013 2:20 pm

Well, although a ProductID of 0x4200 is *close* to a required ProductID of 0x4210, it's not exact. It's a different device/dongle altogether, sorry.

But if it was a ProductID 0x4210 and it still didn't work, now that would be ... something else altogether. (I can't say "good" here because it would be bad!)

Thanks for checking and letting us know.
Cheers,
Janice

SpaceDeep
Posts: 1
Joined: Sun Apr 28, 2013 4:08 am

Re: UWATEC IrDA

Post by SpaceDeep » Sun Apr 28, 2013 4:11 am

Hi support,

I also have Sigmatel version: VendorID - 0x066F, ProductID - 0x4200 IRDA. Will you ever support this HW model or should i try to find correct one - 4210?

support
Posts: 716
Joined: Wed Mar 31, 2010 4:35 pm

Re: UWATEC IrDA

Post by support » Tue May 07, 2013 10:21 am

We have no plans to support this model, although at least it's technically possible. We would first have to have one in house to be able to develop and test with it so someone would have to send us one - the company isn't around anymore so I don't think we could go out and buy one but I don't know this for sure. I haven't seen much demand for it either until these 2 requests though and ScubaPro never shipped it that I know of so there is not a lot of reason for us to do it. If you can come up with a good business case for us to do it, feel free to let us know :-)

I think it would be best if you can find a new IrDA dongle instead. You probably won't get a SigmaTel one and will probably end up with a Mostek one which is also fine.

Thanks,
Janice

espino
Posts: 1
Joined: Sat Oct 26, 2013 2:35 pm

Re: UWATEC IrDA

Post by espino » Sat Oct 26, 2013 2:42 pm

Hi,

I was wandering if you can help

I am having problems with DiveLogDT downloading the dives from my Uwatec Aladin Prime.

I press de button to download but it never completes. I have check the IR log and is created and download the information but the download never gets completed.

I can email the file IRDA-Dumpt.txt if you want to have a look.

support
Posts: 716
Joined: Wed Mar 31, 2010 4:35 pm

Re: UWATEC IrDA

Post by support » Sat Oct 26, 2013 6:00 pm

I can email the file IRDA-Dumpt.txt if you want to have a look.
Yes, please do. And also the IrDA-UWatec.txt and IrDA-UWatec.xml file too. You can email all 3 to support at moremobilesoftware dot com

For DiveLogDT, the files are pretty buried ..... do you already know how to find them? If not just email us and we'll give you directions on where they are.

Sorry for the inconvenience,
Janice

clay
Posts: 4
Joined: Fri Jul 18, 2014 7:49 pm

Re: UWATEC IrDA

Post by clay » Fri Jul 18, 2014 8:08 pm

Hey janice I just bought the app and I'm getting the error message when I plug in my Irda, it has the numbers you previously posted
VendorID - 0x9710, ProductID - 0x7780. I got excited thinking it would work but its giving me an error message saying error initializing Irda device.
Anything I can do besides spending $100 on another one and hoping it works?
Info on device... copied and pasted :D
Product ID: 0x7780
Vendor ID: 0x9710 (Moschip Semiconductor Technology)
Version: 0.01
Speed: Up to 12 Mb/sec
Location ID: 0x14100000 / 4
Current Available (mA): 500
Current Required (mA): 500

support
Posts: 716
Joined: Wed Mar 31, 2010 4:35 pm

Re: UWATEC IrDA

Post by support » Sun Jul 20, 2014 9:16 am

Really? Wow. That's very interesting and I have to say I'm surprised. Of all the random IrDA dongles being manufactured, I would have thought that one using the Mostek chipset would have worked ....I know this won't help you, but you get the prize for being the first Mostek one that *didn't* work :?

So for one, can you send a link or tell me where you purchased the unit? I'd like to find out how long it's been manufactured, i.e.: oldish or newish

Second, are you in a place where you can easily purchase one like this one from Amazon?
http://forums.moremobilesoftware.com/vi ... ?f=8&t=783

It looks like it's not available through Amazon anymore, but you can still get it directly from pccables.com. Spending $20USD plus shipping is generally the cheapest way in terms of both time and money to get things to work. Far cheaper than UWatec ..... I have not yet been able to verify a more "international" source unfortunately.

And third, if you are within reliable snail mail distance to Washington State, you could mail it to me and I could take a look and mail it back to you. I'm just very curious and want to make sure that "newer" manufactured dongles continue to work with DiveLogDT if it is the case that somehow they've made an incompatible change ....

Thanks,
Janice

support
Posts: 716
Joined: Wed Mar 31, 2010 4:35 pm

Re: UWATEC IrDA

Post by support » Sun Jul 20, 2014 9:42 am

Hi Clay,

I just had another thought .... did you find or install another driver for this IrDA dongle? If so, then that (kernel) driver probably "owns" the device and DiveLogDT's driver will not be able to talk to it. MacOS does not allow another driver to talk to a device once another one has "claimed" it.

Let me know,
Janice

clay
Posts: 4
Joined: Fri Jul 18, 2014 7:49 pm

Re: UWATEC IrDA

Post by clay » Sun Jul 20, 2014 6:39 pm

support wrote:Hi Clay,

I just had another thought .... did you find or install another driver for this IrDA dongle? If so, then that (kernel) driver probably "owns" the device and DiveLogDT's driver will not be able to talk to it. MacOS does not allow another driver to talk to a device once another one has "claimed" it.

Let me know,
Janice
I think this may be the problem, I did look for and install a driver for the IrDA. I deleted the file in finder and emptied trash, don't know if there is anything else I can do to make it work. I actually live in Wa state right outside Olympia... if i can't get it to work I'd be happy to mail it to ya... but i'd like to get it to work if I can erase the driver and get the app to claim it.

support
Posts: 716
Joined: Wed Mar 31, 2010 4:35 pm

Re: UWATEC IrDA

Post by support » Mon Jul 21, 2014 8:37 am

Hi Clay,

I'm fairly certain that it's the other driver then that is causing the problem and not the unit itself. I would look for it's "uninstall" instructions and follow that. Simply moving it to the trash is often not enough - it's been copied to /System somewhere and has modified some config files.

Since there has never been a MAC driver for these in the past and the ASIX one just showed up this April, I'm guessing it's that one? If so, the package has an uninstall script you can use. And I would be sure to reboot your Mac after you uninstall and look at the console messages afterwards to make sure the world is still good.

Let us know,
Janice

Post Reply