Page 1 of 1

"Error initializing IrDA device"

Posted: Thu Jan 03, 2019 9:05 am
by carlb
Relatively new user here.

Bought and set up DiveLogDT about a month ago, and successfully downloaded the contents of my Galileo Sol into DiveLogDT. Tried to import latest dives today, and cannot get the IrDA device to work. I get the message, "Error initializing IrDA device." as soon as I unplug the device, the app quits and opens Apple's dialog box for reporting apps that quit unexpectedly. I have tried opening the app with the IrDA device already installed, with the same result. I shut down and restarted my computer, same result. Running DiveLogDT 4.5.3 (4.168) on iMac running macOS High Sierra 10.13.6. IrDA device is the same one I used last month, ScubaPro branded.

Any suggestions for getting things working again?

Re: "Error initializing IrDA device"

Posted: Thu Jan 03, 2019 5:28 pm
by support
We just figured out that there is a problem with the current release of DiveLogDT when running on macOS releases *before* macOS 10.14 (Mojave). A change that Apple made is only valid for 10.14 and doesn't work for earlier releases and we accidentally used it :-(

A new version of DiveLogDT has been submitted to Apple and should be out shortly. Look for a new version 4.5.4.

So sorry for the problem! And Thanks for your understanding.

Re: "Error initializing IrDA device"

Posted: Fri Jan 04, 2019 9:12 am
by support
The new version of DiveLogDT that should resolve the issue you were seeing with initializing the IrDA USB device is now available in the Mac App Store. You should be able to upgrade by visiting the Mac App Store app on your Mac. Please let us know if you are still experiencing difficulties.

Again, apologies for the inconvenience this has caused anyone.