iOS Cloud Sync not working properly

iOS Cloud Sync not working properly

Postby discordare » Sat Oct 04, 2014 12:30 am

I have an iPhone 4 on iOS 7 and an iPad on iOS 8, both operating under the same iCloud account. However, the iPhone cannot see syncs from the iPad and vice versa. Additionally, I can no longer connect the iPad to DiveLogManager using Wifi sync; I can get DiveLogManager to see the iPad, but when I try to back it up or copy a log book I get the following error messages:

Error - service name Jim Ramsey’s iPad, connection didNotResolve: {
NSNetServicesErrorCode = "-72007";
NSNetServicesErrorDomain = 10;

and it times out connecting. The iPhone works fine.
Posts: 1
Joined: Sat Oct 04, 2014 12:25 am

Re: iOS Cloud Sync not working properly

Postby support » Sat Oct 04, 2014 9:31 am


It is possible that the issue with iCloud Synchronization is being caused by you choosing to upgrade to "iCloud Drive" when you upgraded your iPad to iOS 8. You should check to see if your iPad is using iCloud Drive or if it is still using the older "Documents & Data". The easiest way to check this is to open the Settings app on your iPad and tap on "iCloud" and then tap on "iCloud Drive". If that results in a screen offering you the option to upgrade to iCloud Drive then that is not the issue. Do not upgrade to iCloud Drive if you want to be able to synchronize with devices that are not running (or can not run) iOS 8 as iCloud Drive is not available on iOS versions prior to iOS 8. Unfortunately, if you did choose to upgrade to iCloud Drive there is no way to "go back". When you choose to upgrade to iOS 8 Apple migrates all your data from the old "Documents & Data" area available in older version of iOS to the new "iCloud Drive" area and marks your AppleID (i.e. your iCloud account) as now using iCloud Drive. This is a one way trip and it can not be undone. Since your iPhone 4 is not supported by iOS 8 you may be out of luck (unfortunately this is not something we as developers can do anything about - here is an article from that provides some more insight into the transition to iCloud Drive). It might be possible to regain iCloud Sync between your iOS 7 and iOS 8 devices by creating a new AppleID (on your iOS 7 device) and using that for iCloud on both your iOS 8 and iOS 7 devices. However, I do not know for a fact that this will work. If it turns out that you have not upgraded to iCloud Drive, please contact us directly via our support email alias (support 'at' moremobilesoftware 'dot' com) so we can investigate other possible reasons for your current situation.

In general, the current version of Dive Log (1.8.4) works fine on iOS 8 with Wi-Fi synchronization. The problem is most likely being caused by a transient network configuration issue. This can be result from a number of issues (it is possible that it is linked to some reports of Wi-Fi stability issues in iOS 8 reported by some iOS 8 users since it seems to only be affecting your iOS 8 device). I would suggest taking the following steps:

1) Restart your Wi-Fi router by unplugging it from the wall for about 30 seconds and the plugging it back in.
2) Restart your iPad by pressing and holding the "Sleep/Wake" button on the top of your iPad until the "slide to power off" control appears, slide that control and wait for the screen to go blank. Once it does press and hold the Sleep/Wake button again until the device starts up.
3) Verify that you are not connected to the "Guest" network side of your router on either your iPad or Mac if your router supports that feature. All your devices should be connected to the internal network if you want them to be able to talk to each other directly (devices connected to the "Guest" side of the network can only talk to the Internet although they might be "seen" by other devices).

If none of those items helps, you can try:

4) Removing the Wi-Fi connection from your iPad by going into the Settings app and tapping on the Wi-Fi item and then the "i" next to your Wi-Fi connection. Then tap "Forget this Network". You will then need to join the network again and reenter your Wi-Fi password.
5) Try resetting your network settings on your iPad by opening the Setting App again and then visit the General->Reset item and then tap on "Reset Network Settings". This will require that you rejoin and enter your password for each Wi-Fi network you use when you next encounter them.

I hope that helps. If not, please contact us via email and we can diagnose the issues more efficiently.

Best Regards,

Posts: 614
Joined: Wed Mar 31, 2010 4:35 pm

Re: iOS Cloud Sync not working properly

Postby robcw » Mon Jun 08, 2015 6:27 am

I have the same problem with both my iPhone 5s and iPad are both using icloud drive and cannot see each others logbooks how can i fix this?
Posts: 1
Joined: Mon Jun 08, 2015 6:20 am

Re: iOS Cloud Sync not working properly

Postby support » Sun Jun 21, 2015 5:52 pm

Hi Rob,

A couple of things you can try in addition to the suggestions in the post above are:

1) Double check that in the Settings App that the switch next to iCloud->iCloud Drive->Dive Log is "On" on both devices.

2) Turn off the switch next to iCloud Drive on both devices and then turn it back on after a few minutes on both devices. This will reset the iCloud system on your device an cause it to re-sync with Apple's servers.

Finally, remember that iCloud needs to be able to contact Apple's servers before the data is transferred between devices. If you do not allow iCloud Drive to work over Cellular (see the setting under iCloud Drive in the Settings App) or if you do not currently have a good internet connection the data will not transfer until you do. Also, if Apple happens to be having a service interruption the data also will not transfer.

If you are continuing to have troubles, please contact me via email at out "support" at "moremobilesoftware" dot "com" email address and we can take some additional steps to help sort out your situation.


Posts: 614
Joined: Wed Mar 31, 2010 4:35 pm

Return to Dive Log

Who is online

Users browsing this forum: Google [Bot] and 2 guests