Consumption Rates gone

Discussion of the iOS App Dive Log
Post Reply
scubadiverj
Posts: 3
Joined: Sun Jul 28, 2019 9:44 am

Consumption Rates gone

Post by scubadiverj » Sun Jul 28, 2019 9:57 am

I just noticed that the consumption rates read 0. This is for new entries and also previous ones that showed the air consumption rate. Thank you!

Aqualung i550

support
Posts: 689
Joined: Wed Mar 31, 2010 4:35 pm

Re: Consumption Rates gone

Post by support » Sun Jul 28, 2019 10:35 am

Hi,

Can you confirm that you are running Dive Log on iOS 13 beta? If so, that will be the explanation for the problem as Apple has a bug in iOS 13 beta (it is still present in Beta 4) where the API that is used to round values to the nearest factional point (0.33 for example) instead round them all to just the most significant digit (in the case of 0.33 it will round to "0"). I have filed a bug report with Apple and hope that they will resolve this issue soon as it is a very low level and fundamental part of the iOS API's that is causing the issue.

Please let me know if you are running a non-beta version of iOS (12.4 or earlier) so that we can look at other possible causes of the issue.

Thanks,

Greg

support
Posts: 689
Joined: Wed Mar 31, 2010 4:35 pm

Re: Consumption Rates gone

Post by support » Mon Jul 29, 2019 12:56 pm

Hi,

Just a quick follow up on the consumption rate issue that you were seeing. Apple just released iOS13 Beta 5 this weekend and the underlying bug that was leading to the consumption rate showing "0" has been fixed. So an update to iOS13 Beta 5 should resolve your issue. Of course, if it does not, please let me know.

Cheers,

Greg

scubadiverj
Posts: 3
Joined: Sun Jul 28, 2019 9:44 am

Re: Consumption Rates gone

Post by scubadiverj » Wed Jul 31, 2019 5:22 pm

yes, I am running beta. Thank you! With the latest update, everything seems to be working as it should.

Post Reply