Sync Diving Log 6.0 to iPhone App don't work

Sync Diving Log 6.0 to iPhone App don't work

Postby BAfH » Mon Aug 20, 2018 1:48 am

Hi all,

hope anyone can help in this Case.

Last Time i Sync all works fine, now i get a network error ...

Fakts:

Diving Log 6.0 (Up to Date)
Dive Log (iOS is also up to Date)
WLan works fine (with other Software)
No, the Anti Virus Software is not the Problem, it works not with and without the Software.

I think that Apple changed something in the Network part, that youre software can not communicate/load Data with/from other Computers.
Same is it with the IPad.

If you need Logs, just ask.
BAfH
 
Posts: 2
Joined: Mon Aug 20, 2018 1:38 am

Re: Sync Diving Log 6.0 to iPhone App don't work

Postby support » Mon Aug 20, 2018 8:11 am

Hi,

I'm sorry about the difficulties you are having. I don't think that Apple has changed something that is causing your problem. We are not seeing any new general problems with syncing via Wi-Fi between Dive Log on iPhone/iPad and Diving Log 6.0 on Windows. I suspect that there is some sort of configuration in your local network that is leading to the difficulties. It sounds like you have checked most of the likely culprits. However there are a couple of things that I'd like to suggest that you verify:

1) Make sure that none of the iPhone, iPad or PC are connected to the "guest network" side of your router (the guest network allows each device to reach the internet but not be able to reach each other as a security measure). You need to be connected to the "internal network" side of your router. Typically routers are configured with "guest" in the SSID for the guest network (although this is not always the case). Note that coffee shop and hotel internets often use a similar mechanism to protect their customers so if you are not using your home network this could be the issue (let me know and I can provide a workaround).

2) Try restarting your router by unplugging it from the wall for about 30 seconds and then plugging it back in. This will reset the internal cache in eh router (called routing tables) which sometimes get out of date as iOS devices connected and disconnect. It is less likely that this is the issue since it is happening to both your iPhone and iPad but it can also help if the PC's entry has gotten out of date.

3) I know that you said you tried turning off your anti-virus software, however the symptoms that you described are exactly the same as we we caused by a bug in Avast! AntiVirus and AVG Antivirus software. They both have a module (called WebShield) that is incorrectly blocking traffic from Diving Log 6.0 and causes the iPhone/iPad to never see the initial pairing message from the PC. If you completely disable your antivirus software (not just the firewall part of it) then you might find it works. I can provide a ways to turn off just the WebShield component of these products permanently or temporarily if you find this is the issue.

4) It might be worth strung to reboot your PC, iPhone and iPad (press and hold the sleep/wake button on your iOS device until the "slide to turn off" control appears and then slide that, after the screen is completely black press the Sleep/Wake button again to turn it back on).

If the problem persists, then there are diagnostics logs on both the iPhone/iPad and PC that would be helpful to send me. In Dive Log tap the "Enable Sync" button and then tap the "i" in the lower right hand corner to expose the diagnostics log. Now on in Diving Log 6.0, open the Sync dialog and if the iPhone/iPad shows up press the appropriate operation button and wait for the network error message. Then click the "Info" button. On the PC select the text from the diagnostics panel and send that to me. On the iPhone/iPad do the same (you can copy/paste the text using the normal mechanism or take a screenshot). You can email the diagnostics logs to our support email address (support 'at' moremobilesoftware 'dot' com). These should provide the clues that we need to determine what is going on in your network.

Cheers,

Greg
support
 
Posts: 575
Joined: Wed Mar 31, 2010 4:35 pm

Re: Sync Diving Log 6.0 to iPhone App don't work

Postby BAfH » Fri Aug 24, 2018 9:12 am

Hi there,

here are my feedback, with my solution for this Problem.

I checked my complete environment (Router, Firewall, Servers and so on)...
-> Restart the DHCP Service on the Server -> Don't work
-> Check DHCP Config -> Don't work / Nothing found
-> Reboot Watchgurad Firewall -> Don't work
-> Restart DNS Service -> Don't work
-> Check DNS Config -> Don't work / Nothing found
-> Reboot Access Point -> Don't work
-> Check GPO on Windows Domain Controller -> Don't work / Nothing found

Checked Firewall Log for denied packets -> Error Found -> Exception added -> all works fine


Thx for the hint, not to see the wood for the trees, now i see the wood :-D
BAfH
 
Posts: 2
Joined: Mon Aug 20, 2018 1:38 am

Re: Sync Diving Log 6.0 to iPhone App don't work

Postby support » Fri Aug 24, 2018 10:55 am

Excellent! I'm glad that you were able to track down the issue.

Thanks for letting us know what you found. I'm sure it will be helpful for others in the future.

Cheers,

Greg
support
 
Posts: 575
Joined: Wed Mar 31, 2010 4:35 pm


Return to Dive Log

Who is online

Users browsing this forum: No registered users and 2 guests

cron